ホーム » コンピュータ
「コンピュータ」カテゴリーアーカイブ
Postie のトラブル
WordPress も 8月に 7.1 系にアップグレードされたけど、この1年ほどは大きなトラブルもなく更新がでたらポチるだけの安定運用。
ただ、今日は Postie の更新が来ていたので更新をかけたら、起動しなくなった。安定実績のあるプラグインが動かなくなるのは久々だな。
ひとまずは、plugins ディレクトリに入って mv postie postie.disabled で一旦無効化させる。
確認すると、この数日で 1.9.82,83,84,85,86 と微妙に更新がかかっているなか、「注意: このプラグインは現在使用中の WordPress バージョンではテストされていません。」となっている。変な動き…ではなく、WordPress の起動さえ邪魔するようなトラブルは珍しい。
WordPress 本体の更新を確認すると、WordPress 7.1.1 が 9/17, 7.1.2 が 9/22 に自動更新かかっているなぁ。
(2026/09/24 追記)
新しく更新が出たようなので、元に戻して更新で無事復帰。
同様のトラブルが職場の WordPress でも発生。休み明け早々の朝イチ仕事で対応(済)
HomeAssassinにHomeKit Bridgeを登録
iOS27 で Siri AI が強化され、改めて iPhone のホームアプリを使いたくなってきた。
以前は、HomeBridge を使っていたけど、連携などの問題で HomeAssassin に移行したうえで、HomeBridge はお役御免としていた。となると、HomeAssassin で連携させたい。Gemini で聞いてみたら連携機能があるな。
HomeKit Bridgeのインストール
『設定 – 統合を追加 – Apple – HomeKit Bridge 』にて、iPhone ホームアプリ用の QR コードを生成させ、iPhone で読み込ませたら、連携ができた。(統合追加で “Apple – HomeKit デバイス” との勘違いに注意)

動作テスト (9/23追記)
iPhone(iOS27.2β1) の Siri に「リビングの照明を消して」としたら、ちゃんと消してくれた。でも、Apple Watch だと「リビングルームには電力を制御できる照明はありません」と言われる。微妙だな。
次に、複合技の実験で iPhoneで「リビングの照明を1分後に消して」としたら、「ホームハブの設定が必要」とのエラーメッセージ。この機能は、Google の Gemini for Home だと、一応動いてくれる。でも、設定に失敗したりすることもある多い微妙な機能だし、Siri だと動くかなと期待したけど残念。

Raspberry Pi5 はてな Cube
USJ のお土産の「はてなボックス」が、Raspberry Pi5 はてな Cube になりました。
お土産屋さんで、このサイズの箱を見つけたら、こうするしかないと思うよね。
Power Mac G4 Cube ほど洗練されてはいないけど。
![]()
watchOS 27 β で旧暦表示
お試しで Apple Watch に watchOS 27 βを入れたけど、スマートスタックにカレンダーが表示されると、旧暦表示してくれる。βのバグだろうけど直してね。Apple Watch の カレンダーの他の暦を、iPhoneの反映を外し、カスタムで他の暦オフ(最初からオフなのに旧暦表示になってる)で元通り。

9/10(水) 、Apple Watch 12 の発表と共に、watchOS 27 β も更新がかかった。んで、飽きもせず旧暦復活。改めて、他の暦オフ(最初からオフのはずなのに)

SSD のエラーは firmware バグ
サーバの SSD のトラブル検出で smartd を運用しているけど、下記のように平常温度から、瞬発的な高温が記録されるトラブル。
$ sudo smartctl -a /dev/nvme0 : Device: /dev/nvme0, Critical Warning (0x02): Temperature Device info: Samsung SSD 980 1TB, S/N:S649NF0R884403D, FW:1B4QFXO7, 1.00 TB
調べてみると、SSD のファームウェアのバグが原因という情報が見つかる。
対処法: Samsung公式が配布している「Samsung NVMe SSD Firmware」から、ISOイメージ(Linux用ファームウェア更新ツール)をダウンロードし、最新ファームウェアへアップデートしてください。アップデート後にシステムを再起動すると、誤検知が発生しなくなります。
ダウンロードした .iso ファイルを Rufas などで起動ディスクを作って、USB ブートさせればいいらしい。週末にでも適用するか。
firmware update 完了
$ sudo smartctl -a /dev/nvme0 : Model Number: Samsung SSD 980 1TB Serial Number: S649NF0R884403D Firmware Version: 3B4QFXO7
無事に更新できたかな。
raspberry-pi5 の導入
ReadyNAS に debian/forky をインストールし、DHCP, DNS の多重化を行ったが、お下がりの機器だったので HDD のエラーが発生したり、異音がして OS が気絶したりと、安定運用とはできなかった。
しかたがないので、Raspberry-Pi5 で運用することにした。
標準の debian/trixie 64bit でインストールしてひとまず運用の確認をして、早々に debian/forky にアップグレードとした。
bsdextrautils のパッケージインストールで、他のパッケージとの重複で上書きが発生するとのことで、アップグレードに失敗した。しかたがないので、問題のないパッケージをすべてアップグレードを終わらせてから、force-overwrite オプションで無理やりアップグレードを終わらせて、無事 debian/forky に移行を終えることができた。
最終目標は、raspberry-pi3 で動いている TV, CATVSTB など入力切替などで運用している機能を移行させたい。
readynas pro 2のシリアル
ReadyNAS Pro2 に debian/forky をシリアルコンソールを使ってインストールしたけど、再起動に失敗。再起動時にエラーが出た様子。
改めてシリアルコンソールで起動させると、fsck に失敗していた。今後もシリアルコンソールを使う機会がありそうなので、メモ。
3.3V or 5V USB Serial 9600 bps Ready NAS Pro 2 8bit no-parity 4 3 2 1 1bit parity GND RX TX +5V no Flow-control | \/ | /\ GND RX TX +5V +3.3 DTR CP2104 Serial USB
$ brew install minicom $ minicom -D /dev/tty.usbserial-XXXX -b 9600 -8 -o
macOS は、CP210x ドライバが標準組み込み
Silicon Labs 公式: CP210x USB to UART Bridge VCP Drivers

readynas の運用開始と DNS,DHCPの多重運用
NETGEAR の ReadyNAS Pro 2 を入手。readynas の 正規 OS は、バージョンが古く debian ベースの でも samba などが古いプロトコルしか使えないので、便利な使い方ができない。
このため、Serial ポートを使って debian/forky をインストール。
サーバを運用していると、ネットワークの設定を間違って DNS, DHCP を止めてしまうと、自宅ネットワークが全滅する。 Raspberry-Pi で DNS セカンダリサーバなどを動かしていたけど、この readynas のサーバで多重サーバ構成にしたい。
DNS のキャッシュサーバ運用
まずは、DNS (bind9)のセカンダリ運用。
((( /etc/bind/named.conf.local )))
zone "tsaitoh.net" {
type slave ;
file "db.tsaitoh.net.slave";
masters {
192.168.xx.yy;
};
};
((( /etc/bind/named.conf.options )))
acl internal-network {
::1;
127.0.0.1;
192.168.xx.0/24;
};
options {
directory "/var/cache/bind";
forwarders { 192.168.xx.yy; };
allow-query { internal-network; };
allow-recursion { internal-network; };
dnssec-validation auto;
listen-on { any; };
allow-transfer { none; };
};
DHCP のホットスタンバイ運用
続いて、DHCP の多重化。最近まで isc-dhcp-server を使っていたけど、kea-dhcp4-server に切り替えていたが、kea-dhcp4-server では、hot-standby 構成を組めるので、設定。2台の DHCP サーバは、8000 ポートで相互に死活状態を確認し、相手が機能していないと、自身が DHCP 処理を行う。
((( /etc/kea/kea-dhcp4.conf )))
"hooks-libraries": [
{
"library": "/usr/lib/x86_64-linux-gnu/kea/hooks/libdhcp_lease_cmds.so",
"parameters": { }
},
{
"library": "/usr/lib/x86_64-linux-gnu/kea/hooks/libdhcp_ha.so",
"parameters": {
"high-availability": [ {
"this-server-name": "プライマリホスト名", // セカンダリの設定ではセカンダリホスト名を記入
"mode": "hot-standby",
"heartbeat-delay": 1000,
"max-response-delay": 10000,
"max-unacked-clientsets": 5,
"peers": [
{
"name": "プライマリホスト名",
"url": "http://192.168.xx.yy:8000",
"role": "primary"
},
{
"name": "セカンダリホスト名",
"url": "http://192.168.xx.zz:8000",
"role": "standby"
}
]
} ]
}
},
],
これで、メインサーバにトラブルがあっても、自宅内ネットワーク全滅は避けられる。
ssh 多段login
slogin の作業で、中継サーバにログインして、その先のサーバに接続することは多いけど、それを1コマンドでこなす方法ってあったんだ。
$ ssh -J user@中継サーバ user@ターゲット
$ vi ~/.ssh/config
Host 中継サーバ
HostName 中継サーバホスト名
User ユーザ名
Host ターゲット
HostName ターゲットホスト名
User ユーザ名
ProxyJump 中継サーバ
$ ssh-copy-id ターゲット
$ slogin ターゲット
Geminiで朝のお天気報告
お遊びで、朝の起床にあわせて、Gemini を使って天気の報告するように設定したけど、先日プログラム作りでGemini を使ったら、AI利用の無料枠を使い切ったようで、プログラムが動かなくなってる。





